Stai visualizzando 8 post - dal 73 a 80 (di 90 totali)
  • Autore
    Post
  • #3632
    AvatarVincenzoS
    Partecipante

    Mi dispiace per i ricordi volati via… ma a volte ritornano, come per magia.

    #3655
    AvatarVincenzoS
    Partecipante

    Sono lontano dalla CNC per guardarla toccarla e chi sa che cosa testare e come, ma mi vengono in mente domande sceme.

    Eppure se fosse solo rapido (G0)…
    E’ perfetta…
    Non una sbavatura…
    Non un centesimo perso…

    #3657
    Avatartheremino
    Amministratore del forum

    Il Rapid (G0) non ha nessuna differenza dal Feed (G1), solo la velocità.
    Il rapid va alla stessa velocità di MaxSpeed e quindi non c’è la grande sproporzione tra MaxSpeed (2000) e Feed (50)
    Abbassa MaxSpeed a 500 o anche a meno.
    Non so più come dirtelo.

    #3674
    AvatarVincenzoS
    Partecipante

    Ho eseguito il test a 500/50 ed i vari test ad esecuzione breve non producono errori evidenti.
    File GRANDI, producono errori, dopo una mezzora di lavoro trovo errori anche di 0,2mm.
    E’ vero che i tempi corrispondono o quasi ma in queste condizioni è lentissima quando c’é da fare tratti lineari.
    A proposito, no so se si può fare o non lo so fare io adesso, quando si manda in pausa un lavoro sarebbe utile spostare in automatico la Z in zona di sicurezza per evitare il contatto con il materiale.
    Soprattutto con il legno una punta che staziona troppo nello stesso posto produce bruciature del materiale con pericolo d’incendio.

    #3676
    Avatartheremino
    Amministratore del forum

    Se succede questo allora non puoi usarlo con GCode molto lunghi.

    I “tratti lineari” sarebbero i “Rapidi” ?
    Se è così, per quanto lenti, non dovrebbero incidere sul tempo finale che di una percentuale trascurabile.

    Riguardo al bruciare il legno quello che dici mi sembra impossibile, dopo un secondo la punta ferma ha mangiato tutto quello che poteva mangiare e non succede più niente.

    #3711
    AvatarVincenzoS
    Partecipante

    Peccato…

    #3713
    AvatarLeo
    Partecipante

    Vincenzo,
    Io sono sempre dell’avviso che potresti avere un problema nel PID dei motori stepper controreazionati.
    I problemi che manifesti, io non li ho e utilizzo semplici ed economici motori stepper.

    #3717
    AvatarVincenzoS
    Partecipante

    Salve, come richiesto, ho messo su il vecchio sistema con i vecchi stepper nema 23 3Nm pilotati dai driver drw8825 e Master sia nuovo che vecchio il tutto collegato a diversa rete elettrica.

    L’immagine collegata mostra l’errore così come con i motori closed loop.

    I motori non sono collegati meccanicamente, sono sul tavolo.

    I test sono stati effettuati con le stesse modalità finora eseguite, inoltre ho eseguito il test random con Automation che ha prodotto il solito risultato di precisione assoluta.
    Il file “grande” che produce l’errore non è che poi sia così grande (parliamo di circa 28000 righe per un lavoro di circa 10x20cm)… immagino con alcuni che vorrei realizzare da oltre 200k righe.

    Saluti.

    https://my.pcloud.com/publink/show?code=XZxaQW7ZgIp9zjNOGXzbv4jToRNeuLTaVuvV

    • Questa risposta è stata modificata 2 anni, 4 mesi fa da AvatarVincenzoS.
    • Questa risposta è stata modificata 2 anni, 4 mesi fa da AvatarVincenzoS.
Stai visualizzando 8 post - dal 73 a 80 (di 90 totali)
  • Devi essere connesso per rispondere a questo topic.