Stai visualizzando 5 post - dal 1 a 5 (di 5 totali)
  • Autore
    Post
  • #10471
    gvsoft
    Partecipante

    Saluti a tutti gli E.A. amici
    Sarò anche un ignorante in materia ma chissà perchè poi le cose le faccio funzionare. Qualcuno mi sa spiegare a cosa può servire una R da qualche decina di migliaia di OHM posta tra VCC e GND ?. Mi spiego meglio: ho comprato un adattatore per ESP8266 molto semplice e microscopico ma molto utile per provare gli ESP su breadboard: infatti il connettore dell’ ESP non consente l’inserimento in una breadboad. L’ adattatore distribuisce su due file tutti i pin dell’ESP in modo da poterlo inserire appunto su una breaboard. Tutto ok: comincio le prove dello sketch che prevede l’uscita RX/TX dell’ ESP verso un serial monitor per verificare i passi dello sketch. Dopo aver fornito VCC a 3V il serial monitor non ne vuole sapere di attivarsi anzi continua una spece di ON/OFF provocando addirittura un crash totale del PC e conseguente riavvio. Verifico tutto quanto può essere verificabile e non trovo errori di nessun tipo. Provo senza l’adattatore e tutto funziona. Chiaro a questo punto dovè il problema: Riverifico le connessioni: tutto ok: Mi accorgo però che sull’ adattatore c’è cablata una microscopica R SMD (in serigrafia c’è scritto ESD). Provo a verificare con il tester e vedo segnare parecchie migliaia di OHM. Verifico i due estremi e scopro che da un ramo è connessa a VCC e l’altro ramo a GND (!!!!). Decido allora di cannibalizzare questo adattatore e ESTIRPO brutalmente detta R. RIfaccio le prove: tutto OK ! . Il serial monitor funziona e pure lo sketch caricato sull’ ESP. Rifaccio la controprova sostituendo l’adattatore con un altro uguale (con la R) e ritrovo i problemi di prima. RIifaccio la domanda: a che c….. server questa R ??? A creare problemi ??? !!!!
    Grazie ragazzi per avermi sopportato.
    giovanni

    #10473
    Just4Fun
    Partecipante

    Magari una foto avrebbe aiutato…
    Provo ad ipotizzare. Se la serigrafia riporta ESD magari non è una resistenza, ma un soppressore per eventuali scariche elettrostatiche (te lo puoi immaginare come una specie di zener x alte tensioni). Magari è pure fallato (TVS unidirezionale messo al contrario…???), visto che posto a VCC = 3.3V non dovrebbe intervenire e risultare come un circuito aperto.

    Esempio di utilizzo su USB:

    Se fosse una resistenza anche di soli 1000 Ohm posta tra VCC (3.3V) e GND non avrebbe nessuna influenza, visto che farebbe scorrere soli 3.3mA.
    Evidentemente così non è.
    Forse il cinesino di turno temeva transitori sull’alimentazione. Mah…

    #10475
    gvsoft
    Partecipante

    Ti ringrazio della risposta: ma tre adattatori su tre presentano lo stesso problema: se connetto RX/TX dell’ESP ad un convertitore FTDI per monitorare quello che succede nello sketch (tipico per il debug) c’è un continuo reset. Adesso voglio fare una ulteriore prova: Lo sketch prevede che se non arriva un segnale dalla seriale non si avviano i messaggi sul monitor; quindi provo un un altro adattatore senza connettere FTDI e quindi senza usare la seriale. Voglio vedere quello he succede. TI farò sapere.
    Intanto grazie.
    Giovanni

    #10477
    gvsoft
    Partecipante

    NON CI CAPISCO PIU’ NULLA:
    Ho fatto la controprova senza usare la connessione seriale quindi senza connettere FTDI: ok tutto funziona anche con l’adattatore orignale non cannibalizzato.
    Ho rifatto la prova connettendo la seriale FTDI per avere i messaggi sul monitor e con mia grande sorpresa FUNZIONA senza problemi.
    Allora mi domando: sono io che ormai ho raggiunto “la demenza senile” per cui prendo fischi per fiaschi oppure è meglio che cambi hobby…..??
    Purtroppo non posso rifare le prove con il pcb su cui ho saldatol’adattatore: il circuito è di una semplicità estrema in quanto ci sono soltanto i connettori per VCC/GND , per il BMP180 e il pulsante di reset: tutto verificato e riverificato alla nausea e infatti funziona.
    A questo punto mi scuso se ho creato un falso problema (ma ho ancora dei dubbi !!)
    Grazie per la Vs attenzione
    Giovanni

    #10498
    Picmicro675
    Moderatore

    Per quello che ho fatto io, direi che è meglio usare un adattatore USB-UART a 3,3V. Io ho preso uno con PL2303HX.Cavetto.
    Ne ho anche un altro, ma non mi sono mai fidato a collegarlo con dispositivi a 3,3V. Mentre con il suddetto ho collegato bene un ESP01 e anche il Tinkerboard (simile al RPi 3).

    Sono contento che hai scritto al forum, mi venivano i dubbi se ci siamo persi in qualche punto. Non importa se sono cose di poca importanza, ben lieti di scrivere.

Stai visualizzando 5 post - dal 1 a 5 (di 5 totali)
  • Devi essere connesso per rispondere a questo topic.