Stai visualizzando 15 post - dal 31 a 45 (di 289 totali)
  • Autore
    Post
  • #5498
    Amilcare
    Amministratore del forum

    In pratica il circuito disegnato da A_X_C pilota gli SSR-25 quando si accende il led originario. Quelli che tu chiami led aggiuntivi sono solo la rappresentazione del circuito di ingresso interno degli SSR disegnati all’interno del rettangolo denominato SSR uno con uscita a triac per la tensione alternata e uno con transistor per la tensione continua.
    Quando il pin2 dello integrato va a massa si accende il led e di conseguenza si attivano gli SSR che stanno in parallelo al led originario.
    Non essendo più presente un transistor lo integrato non dovrebbe rompersi perché la corrente massima erogata e circa 30mA, 10 per il led e 10 +10 per i due SSR. La corrente totale è comunque inferiore a 50mA che è il massimo erogabile da quel pin. Mi raccomando le resistenze di limitazione da 1k servono a salvare lo integrato e non vanno eliminate.
    Se collegassi i negativi degli SSR a massa sarebbero sempre attivi e non avresti un regolare funzionamento.
    Se hai la possibilità di crearti un piccolo stampato e hai la pazienza di aspettare che ho un po’ di tempo libero vedo di realizzare un clone del tuo integrato da inserire nello zoccolo originale ma composto da componenti di facile reperibilità e a basso costo.

    • Questa risposta è stata modificata 9 mesi, 1 settimana fa da Amilcare.
    • Questa risposta è stata modificata 9 mesi, 1 settimana fa da Amilcare.
    #5503
    AvatarIvo
    Partecipante

    Niente da fare, bruciato anche il terzo integrato, mi arrendo!

    Ho scollegato tutti i relay, ho ricontrollato tutti gli altri collegamenti, i semiconduttori, le resistenze e i condensatori. Ho rifatto le saldature, controllate con lente a 8X. Ho controllato pin to pin eventuali corti sullo zoccolo vuoto dell’integrato e su altri componenti. Ho pulito la PCB con alcool e spazzolino e, dopo tutti questi controlli e scollegamenti l’integrato si brucia ugualmente. Mi è rimasto un solo integrato ma non lo sacrificherò, lo terrò come eventuale ricambio per il carica batteria funzionante con il relay Finder, non si sa mai. E pensare che di questi carica batteria ne ho costruiti 2 esemplari con i relay Finder senza mai bruciare un solo integrato.

    Che ci sia qualcosa che non va è una certezza ma quel che è peggio è che l’incognita è talmente occulta che non la rilevo. Comunque, adesso, con un solo integrato superstite, trovo inutile cercare di risolvere il problema occulto che brucia l’integrato originale, sarei comunque intimorito a dare corrente al circuito, non mi fiderei.

    Scusa Amilcare, ma se quello schema è corretto allora non riesco a capire come potranno funzionare le soglie, collegando il comando positivo del relay al positivo della batteria e del generatore di corrente, dove vedo collegata anche la commutazione in DC. Ovviamente non lo capisco per un mio limite. Non riesco a capirlo ma cercherò di ragionarci su, magari prima o poi riuscirò a capire. Ok sulla spiegazione dei LED.

    Hai detto che quell’integrato si potrebbe clonare con altri componenti. Io non sono in grado di farlo in autonomia, soprattutto se devo far coincidere la zoccolatura attuale. Ovviamente non ho fretta e se riesci a clonarlo tu, magari rispettando la zoccolatura, proverei a realizzarlo con un pezzo di basetta mille fori.

    Grazie ancora Amilcare e A_X_C, rimango in passiva attesa, salvo soluzione in extremis.

    #5507
    Amilcare
    Amministratore del forum

    Come hai detto tu qualcosa non va, io non posso a distanza capire dove sia il problema. Con integrato smontato controlla con il multimetro pin to pin il valore resistivo tra positivo e massa se corrisponde con i valori che dovresti avere da schema.
    Per esperienza personale una svista nella realizzazione dello stampato è sempre possibile, magari invertendo o omettendo qualche collegamento o sbagliando Pin.

    #5509
    AvatarIvo
    Partecipante

    Grazie per l’aiuto Amilcare, hai fatto anche troppo. Proverò a fare un po’ di controlli approfonditi ma per mero principio, non avendo più integrati da rischiare. Il metodo utilizzato fino ad ora evidentemente non è affidabile. Se riuscirai a clonare l’integrato sarà un evento epico e sarò lieto di attuarlo. Ti terrò informato su eventuali risultati positivi. Grazie ancora e un cordiale saluto
    .

    #5517
    Amilcare
    Amministratore del forum

    Una prima bozza del clone è questa, naturalmente devo verificarla per correggere eventuali sviste o errori sempre possibili quando faccio le cose dopo cena con una giornata pesante di lavoro alle spalle.
    Aspetta a partire in quarta, devo rivedere tutto a mente fresca e simulare il circuito al simulatore,

    ++++ Caricamento immagine FidoCad ++++
    vedi sorgente fidocadJ Zoom fidocad
    #5519
    Amilcare
    Amministratore del forum

    Come vedi il circuito è semplice ed i pallini grandi sono i pin dell’integrato originario

    • Questa risposta è stata modificata 9 mesi, 1 settimana fa da Amilcare.
    • Questa risposta è stata modificata 9 mesi, 1 settimana fa da Amilcare.
    #5524
    AvatarIvo
    Partecipante

    Magnifico! Ma con un LM358 e otto componenti passivi si riesce a clonare quella bestia d’integrato che costa una fortuna? Dal datasheet del TCA965 si evince una complessità strutturale molto più sofisticata… Ritieni che abbiamo voluto strafare per giustificarne il prezzo? A parte il fatto che quando li ho acquistati avevano un prezzo irrisorio, è adesso che costano un ladrocinio…

    #5528
    Amilcare
    Amministratore del forum

    Quello integrato è sfruttato nel kit a 1/10 delle sue possibilità ed io ho clonato solo quel decimo.
    Tu pensi che se mettevano lo Lm358 qualcuno avrebbe comperato il kit?
    Nel pomeriggio se sono libero sostituisco il mio clone nello schema originario e vedo se ho commesso qualche errore.
    Non ti garantisco nulla perché questi giorni sono sommerso dal lavoro e quello ha la priorità, il sito mi porta solo spese mentre il lavoro mi garantisce il sostentamento.
    Capirai che tra i due sono costretto a scegliere quello che permette la vita di entrambe le cose.

    #5530
    AvatarIvo
    Partecipante

    Ok Amilcare, il lavoro ha sempre la precedenza.

    Mi avevano detto che NE utilizzasse determinati componenti anche come fonte di guadagno pubblicitario. Sembra che un tempo, i produttori di componenti, non essendoci internet, si avvalessero molto più di oggi dell’editoria tecnica per promuovere i loro prodotti. Vabbè sia come sia, oggi è cambiato tutto.

    A proposito, mi hanno detto che il comparatore si potrebbe “clonare” anche con gli LM393, LM311 e LM339 ma, per quanto mi riguarda, tra il dire e il fare…
    Ricordati che quel circuito potrebbe arrivare a ricevere alimentazioni anche superiori ai 21V.

    #5534
    Amilcare
    Amministratore del forum

    I comparatori puri possono andare, escluderei quelli a collettore aperto tipo LM311.
    Ho scelto il LM358 perché lavora benissimo con tensione singola e costa poco oltre che comunissimo perciò anche il tuo fornitore di fiducia sicuramente lo ha. Ha solo 8 pin perciò con una piccola basetta fatta ad arte potrà essere inserito al posto del tuo introvabile integrato originario, senza modificare nulla.
    Inoltre sopporta fino a 32V di alimentazione, molto al di sopra della massima tensione che trovi nel tuo circuito.
    Altre soluzioni sono sempre possibili, se qualcuno ha idee migliori si faccia pure avanti che non mi offendo di certo, non sono il depositario delle verità assolute.

    #5536
    AvatarIvo
    Partecipante

    Nessun problema Amilcare, ti ho soltanto riferito un’informazione ricevuta da una persona che me l’ha segnalata in modo esclusivamente discorsivo e limitandosi a dirmi di provare, come se non gli fosse noto di non essere personalmente in grado di progettare alcunché. In pratica, è come se mi avesse implicitamente detto: si può ma fattelo da solo, c’est plus facile…

    La tua soluzione è interessante e adesso cercherò nei cassettini se dispongo di qualche esemplare del integrato, altrimenti ne acquisto qualcuno e li tengo a disposizione.

    Grazie ancora.

    #5538
    AvatarIvo
    Partecipante

    Permetti una precisazione Amilcare, L’integrato siglato LM358P va bene o la P identifica un parametro particolare?

    #5540
    Amilcare
    Amministratore del forum

    Non preoccuparti è usato come comparatore e le caratteristiche necessarie al tuo circuito sono garantite per qualunque versione tu sia in possesso

    • Questa risposta è stata modificata 9 mesi, 1 settimana fa da Amilcare.
    • Questa risposta è stata modificata 9 mesi, 1 settimana fa da Amilcare.
    #5547
    AvatarIvo
    Partecipante

    Grazie Amilcare, allora sono tranquillo.

    #5558
    AvatarIvo
    Partecipante

    Grazie A_X_C e in particolare ad Amilcare.
    Ti chiedo la gentilezza di riferire ad Amilcare che prima di assemblarlo devo scoprire per quale motivo si sono bruciati tre integrati originali. Se lo collegassi senza quella precauzione sono quasi certo che brucerei anche il clone. Il guaio è che continuo a controllare e a fare misurazioni sulla PCB senza integrato, ma sembrerebbe tutto in regola, non riesco a vedere l’errore, che a questo punto è che certo che ci sia anche se non riesco ad identificarlo.

    In ogni caso sono molto contento della realizzazione. Se funzionerà senza problemi sarà un lavoro di eccellenza, non tanto per la complessità del circuito che Amilcare, a quanto pare, ha realizzato quasi a occhi chiusi, ma per aver sostituito un componente fuori produzione che viene fatto pagare in modo esagerato.

    Grazie ancora, ci aggiorniamo, un cordiale saluto.

Stai visualizzando 15 post - dal 31 a 45 (di 289 totali)
  • Devi essere connesso per rispondere a questo topic.