Stai visualizzando 8 post - dal 137 a 144 (di 289 totali)
  • Autore
    Post
  • #6057
    Amilcare
    Amministratore del forum

    La resistenza in serie è una protezione inutile e per i test non è importante tanto entrambi i circuiti sia quello vecchio che il nuovo hanno la sola funzione di dividere la tensione da controllare per un fattore X dipendente dal valore della tensione di riferimento interna.
    Vedrai che al variare della tensione di alimentazione (tensione della batteria) il comportamento sarà quello desiderato con le soglie di attacco e stacco impostate. Con qualche numero provo a spiegarti perché non cambia quasi nulla.
    Consideriamo la tensione massima a fine carica 14, 5V/(10k+1k)=1.3mA =19mW mentre 14,5 V/10k=1,4mA = 21mW come vedi la variazione è inrilevante sia per gli assorbimenti sia per la dissipazione del trimmer che nella peggiore delle ipotesi è di almeno 100mW.

    #6059
    Ivo
    Partecipante

    Un’ultima info, la resistenza da 27K, che determinerebbe il valore ideale, ti riferisci a quella attualmente contrassegnata con 22K e che andrebbe “selezionata” a 27K precisi?

    #6061
    Amilcare
    Amministratore del forum

    Sarebbe la somma della 22k più il potenziometro in serie per aggiustare il valore esatto, piu o meno col potenziometro a metà corsa dovresti essere al valore desiderato, poi aggiusti le soglie spostandosi un poco fino al valore esatto.
    Se fosse stato un progetto nuovo e non avessi dovuto usare i componenti già in uso avrei usato una resistenza fissa senza regolazioni, minori tarature e funzionamento garantito già al primo colpo

    #6063
    Ivo
    Partecipante

    Niente da fare Amilcare. Ho avuto poco tempo e non ho potuto fare tutte le prove ma quelle che ho potuto fare non sono confortanti. Comincio a temere di aver sbagliato qualche collegamento ma purtroppo non lo vedo. Ho anche problemi di vista e quei fili di metallo che entrano ed escono dai mille fori metallici mi confondono la visuale purtroppo.

    Comunque ti elenco di seguito i valori che ho rilevato:

    Con clone isolato dalla PCB e alimentato a 12,5 Volts:

    Pin 1=0 Volts;

    Pin 2=1 Volts instabile come se ci fosse un’auto oscillazione o un disturbo esterno che interferisce;

    Pin 3=6,72 Volts.

    Con clone collegato alla PCB e alimentato a 12,5 Volts e tensione di 6,25 Volts sul centrale di R11:

    Pin 1=11,19 Volts;

    Pin 2=6,25 Volts stabili senza auto oscillazione o disturbo esterno che interferisce;

    Pin 3=7,05 Volts.

    Il trimmer R8 è ancora completamente ininfluente, anche se ho dimenticato di misurare la tensione direttamente ai suoi capi, potrò farlo domani. Quello che posso dire è che ruotandolo non succede niente.

    Variando la tensione dell’alimentatore stabilizzato, i led si accendono a 14,45 Volts e non si spengono neppure aumentando la tensione a 20 Volts. Sembrerebbe che la soglia massima non sia controllabile.
    In compenso per spegnere i led bisogna scendere di tensione fino a 12,7 Volts ma non si riaccendono finché non si ritorna a 14,45 Volts.

    Credo di aver scritto tutto. Se mi verrà in mente altro ritornerò in argomento…

    #6065
    Amilcare
    Amministratore del forum

    Domani cerco di trovare un po’ di tempo per realizzarlo su breadboard in fondo sono pochi componenti in croce così vedo dove sta il problema.

    #6067
    Amilcare
    Amministratore del forum

    Credo di aver capito il problema, il circuito ha comportamento opposto a quanto dovrebbe.
    Fai un piccolo test sulla schedina da sola collega il led in uscita verso massa invece che verso il positivo, se va allora lo schema iniziale disegnato da A_X_C ha gli ingressi invertiti.

    #6069
    Ivo
    Partecipante

    Ma giusto per non fare errori: collego l’anodo del led al pin 1 e il catodo al pin 4 del operazionale (con in mezzo la resistenza)?
    Sempre alimentando il clone a 12,5V?

    #6071
    Amilcare
    Amministratore del forum

    Si con alimentazione che varia da 11 a 17V per avere test completo di tutte le combinazioni possibili in quanto inizialmente si attiva solo se la tensione è inferiore alla soglia minima e si stacca una volta raggiunto il livello max che equivale a batteria carica. Poi fino a che non scendi sotto al valore minimo non si riattiva

    • Questa risposta è stata modificata 2 anni fa da Amilcare.
    • Questa risposta è stata modificata 2 anni fa da Amilcare.
Stai visualizzando 8 post - dal 137 a 144 (di 289 totali)
  • Devi essere connesso per rispondere a questo topic.