Stai visualizzando 4 post - dal 1 a 4 (di 4 totali)
  • Autore
    Post
  • #8746
    Picmicro675Picmicro675
    Moderatore

    Ciao forum,
    Sto facendo delle prove con un PIC16F877A. Devo capire se ho bruciato le uscite di SCLK e SDA perché non sono in grado di vedere alcun risultato.
    Cercando di pilotare un PCF8574 per interfacciare un LCD 16×2, ma se metto l’analizzatore logico sui due piedini il segnale rimane alto e piatto.

    Se mi indicate qualche idea per provare, vi ringrazio del vostro aiuto.

    #8750
    Just4FunJust4Fun
    Partecipante

    Usa i due piedini come normali GPIO e fai blinkare un led, così vedi se funzionano.

    • Questa risposta è stata modificata 3 settimane, 4 giorni fa da Just4FunJust4Fun.
    • Questa risposta è stata modificata 3 settimane, 4 giorni fa da Just4FunJust4Fun.
    #8755
    Picmicro675Picmicro675
    Moderatore

    Grazie Just4Fun,
    Non sono arrivato a quel punto, sono stato più fortunato. Ora vedo la luce in fondo al tunnel. La buona stella mi da una mano. Forse perché ho cambiato le resistenze di pullup da 4k7 a 10k.
    Sono alla seconda fase per capire qual indirizzo dovrei richiedere. Se faccio la prova con arducoso, mi da 0x27, se lo faccio col PIC mi da 0x47.
    Alla fine dovrei trovare la via per accendere il display e vederci il messaggio 😛

    #8778
    Picmicro675Picmicro675
    Moderatore

    Ora va bene, ma sembra che le routine che sto usando consumano troppi salti e vado in overflow.

Stai visualizzando 4 post - dal 1 a 4 (di 4 totali)
  • Devi essere connesso per rispondere a questo topic.