#3949
Avatartheremino
Amministratore del forum

Utilizzare il 5 volt non determina problemi.
Il resistore da 2.2 k non può che ridurre la sensibilità, non aumentarla.
Tenere R1 al massimo non va bene (eventualmente va cambiato con 10K o più).
Avere 2 o 3 volt alla uscita non va bene, devi partire da circa 100 millivolt con 0 NTU e questa tensione deve salire man mano che la torbidità aumenta.
Se non riesci a regolare per 100 mV con 0 NTU allora vuol dire che il transistor riceve poca luce. (Il LED è puntato bene? Il foto-transistor funziona bene ed ha il collettore ed emettitore non invertiti?)
Se non riesci a regolare per 100 mV con 0 NTU, allora potresti aumentare il valore del trimmer dello zero a 10K o anche a 47K.
Con 2 o 3 volt in uscita fai lavorare il 358 vicino alla saturazione e quindi lavora in modo strano e forse questo è il motivo per cui hai il segnale invertito.

Lo schema è giusto e la tensione di uscita deve aumentare quando aumenti la torbidità
– Aumentando la torbidità il fototransistor riceve meno luce
– Quindi il fototransistor fa passare meno corrente
– Quindi la tensione sull’ingresso negativo del 358 tende a scendere
– Quindi la tensione sulla uscita tende a salire

Per me dovresti:
Eliminare il resistore da 2.2 K.
Regolare R1 per 100 mV circa con 0 NTU .
Se il guadagno non ti basta aumenterai R4 magari a 100k, o anche a 1 mega .
Più alzi R4 e più aumenta il guadagno ma diventerà anche più difficile regolare R1 (che deve sempre essere regolato per 0 BTU = 100mV).

Se non riesci a farlo funzionare
Scrivimi a “engineering chiocciola theremino punto com”, così ci parleremo per telefono o Skype e lo metteremo a posto.