#3389
Avatartheremino
Amministratore del forum

Ora si comincia a ragionare.
Evidentemente sono le vibrazioni che si verificano durante il lavoro.

Mi scrivi quanto usi nell’HAL di Max Speed e di MaxAcc?
Lo sai che acc normalmente deve essere meno di un decimo di speed e che se c’è molta massa da spostare allora la accelerazione va diminuita ancora?
Poi c’è da considerare che i motori andrebbero isolati dalla massa con cinghie elastiche, altrimenti in alcuni momenti di particolari vibrazioni perdono passi.

Tutto questo non è sicuramente dovuto all’HAL e nemmeno al Master.

Ma scusa, se i motori perdono passi, non dovrebbero continuare a spingere fino a che si mettono in pari?
Se non è così allora quei motori non servono a niente.

—-

Ci ho pensato ancora e il mio intuito mi dice che il motore della colonna perde passi quando lo sposti lateralmente.
Quando lo sposti lateralmente in alcuni istanti l’inerzia della massa del motore piega la colonna e provoca un maggiore attrito allo spostamento verticale.
E ci sono dei momenti che l’attrito supera la coppia del motore verticale (che già fa fatica di suo) e così lui sgrana.

Consiglierei di abbassare la accelerazione dell’asse verticale.
E anche abbassare le accelerazioni degli altri due assi in modo da evitare che producano strappi e vibrazioni alla colonna.
E anche di aumentare i microstep per ridurre le vibrazioni.
E aggiungere una cinghia che disaccoppi eleasticamente il motore verticale dalla massa che deve muovere.

Ciao
Livio